Help PT will not start

View previous topic View next topic Go down

Help PT will not start

Post  Jan53 on Thu Sep 18, 2014 7:08 pm

Can anyone help replaced engine coolant temperature sensor on my W (2000 reg) petrol PT , now it will not start. When you try to start
Red alarm / imobiliser light is on radio and lights ,windows etc all work including alarm. Appears to be no power to starter motor just as if clutch has not been pressed .Anyone any idea what the problem may be?

Jan53

Posts : 2
Join date : 2014-09-15

Back to top Go down

resolution?

Post  FastFerret on Fri Oct 24, 2014 9:02 am

Hi,
did you ever get to the source of this issue?

I need to change my temp. sensor and wonder if it was related to your changing the temp. sensor or not.

FastFerret

Posts : 9
Join date : 2014-05-28

Back to top Go down

No Resolution

Post  Jan53 on Fri Oct 31, 2014 7:52 am

Hi,

No have not resolved this issue it appears to be electrical. Garage ran a diagnostics fault test but still do not know the cause.
I have been told the only way to possible get to the bottom of the problem is to take it to a Chrysler dealer.As Chrysler do not release all technical data required.SO my PT is still off the road.
Regarding changing temp sensor do not know if this caused the issue.

Jan53

Posts : 2
Join date : 2014-09-15

Back to top Go down

curioser and curioser...

Post  FastFerret on Fri Oct 31, 2014 8:39 am

that is strange.
I've done my fair bit of motor repair and vehicle rebuild over the year and know that there is a basic process of testing that has to be done before the fault is found.
So did the garage not give you any idea of the fault?
basic checks such as spark, fuel delivery etc can be checked without spinning the starter motor over. Did anyone try to bump start it? This would at least identify that the problem lies between the ignition switch (a known problem on these vehicles) and the starter motor itself.
The starter motor can be bypassed with the one connector of jumper cables to get the motor spinning over and thus eliminate the start motor itself and then it is a matter to trace back to the starter relay/fuses and the ignition switch.

The clutch switch can also be bypassed to ensure this is not the cause and of course, plugging the old temp switch into the plug without installing it into the engine will take the new switch out of the equation.

personally I love a mystery which is probably why I own one of these beasts myself but I've also had a few alfas which is why I have no hair left!

FastFerret

Posts : 9
Join date : 2014-05-28

Back to top Go down

Re: Help PT will not start

Post  Sponsored content Today at 6:00 pm


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum